summaryrefslogtreecommitdiffstats
path: root/sherlock.scm
diff options
context:
space:
mode:
Diffstat (limited to 'sherlock.scm')
-rw-r--r--sherlock.scm62
1 files changed, 29 insertions, 33 deletions
diff --git a/sherlock.scm b/sherlock.scm
index 3168274..a6f787a 100644
--- a/sherlock.scm
+++ b/sherlock.scm
@@ -81,42 +81,38 @@
(license expat)))
(define-public python-sherlock
- (package
- (name "sherlock")
- (version "501cb3dce27494265a0993335dab517070dadab5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sherlock-project/sherlock.git")
- (commit version)
- ))
- (sha256
- (base32 "0lb1r5fkwxm1zyxsax5aq3gp77gjz22i0agz6zyw5j9zrwb7c5g9"))
- ))
- (build-system pyproject-build-system)
+ (package
+ (name "sherlock")
+ (version "0.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sherlock_project" version))
+ (sha256
+ (base32 "0429hxlh8s4xaz1gpc30c86lmpwdy81ffhq7y2gh70nll2cfzqhs"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:tests? #f
#:phases #~(modify-phases %standard-phases
(delete 'sanity-check) ;we're going crazy, since sanity crashes.
)))
- (native-inputs (list
- python-poetry-core
- ))
- (propagated-inputs (list python-certifi
- python-pandas
- python-colorama
- python-pysocks
- python-requests
- python-exrex
- python-torrequest
- python-requests
- python-requests-futures
- python-stem))
- (home-page "https://github.com/sherlock-project/sherlock")
- (synopsis
- "Hunt down social media accounts by username across social networks.")
- (description
- "Hunt down social media accounts by username across social networks.")
- (license expat)))
+
+ (native-inputs (list
+ python-poetry-core
+ ))
+ (propagated-inputs (list python-certifi
+ python-colorama
+ python-openpyxl
+ python-pandas
+ python-pysocks
+ python-requests
+ python-requests-futures
+ python-stem
+ python-torrequest))
+ (home-page "https://sherlockproject.xyz/")
+ (synopsis
+ "Hunt down social media accounts by username across social networks")
+ (description
+ "Hunt down social media accounts by username across social networks.")
+ (license expat)))