summaryrefslogtreecommitdiffstats
path: root/bugwarrior.scm
diff options
context:
space:
mode:
Diffstat (limited to 'bugwarrior.scm')
-rw-r--r--bugwarrior.scm67
1 files changed, 48 insertions, 19 deletions
diff --git a/bugwarrior.scm b/bugwarrior.scm
index e192602..bb1c827 100644
--- a/bugwarrior.scm
+++ b/bugwarrior.scm
@@ -1,9 +1,11 @@
(define-module (bugwarrior)
+ #:use-module ((guix licenses) :prefix license:)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages glib)
#:use-module (gnu packages python)
+ #:use-module (gnu packages openstack)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
@@ -21,10 +23,39 @@
#:use-module (guix licenses)
#:use-module (guix packages)
)
+
+(define-public python-dogpile.cache
+ (package
+ (name "python-dogpile.cache")
+ (version "1.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "dogpile.cache" version))
+ (sha256
+ (base32
+ "0kpx42vxzss4sz5ic6mp01a97zinzm6q76n8li2gbi4ccfxyhi6q"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (native-inputs (list python-mako python-pytest))
+ (propagated-inputs (list python-decorator python-stevedore))
+ (home-page "https://github.com/sqlalchemy/dogpile.cache")
+ (synopsis "Caching front-end based on the Dogpile lock")
+ (description "@code{dogpile.cache} is a caching API which provides a
+generic interface to caching backends of any variety, and additionally
+provides API hooks which integrate these cache backends with the locking
+mechanism of @code{dogpile}.")
+ (license license:expat)))
+
(define-public python-bugwarrior
(package
(name "python-bugwarrior")
- (version "71efc97435a442646782dcb0979df43f69ce955d")
+ (version "ce92e3a4f05f5d78e13d2924c27d8743813fb2f9")
(source
(origin
(method git-fetch)
@@ -32,7 +63,7 @@
(url "https://github.com/GothenburgBitFactory/bugwarrior.git")
(commit version)))
(sha256
- (base32 "0d22av15dyan6yzhqxx01sf45i2fnk1i92wyh9hahfhmv3gawnj1"))
+ (base32 "0v96zg2ga8cw84zx12dvh3m995adf5k40x9cs53waxranxvm4k0a"))
(modules '((guix build utils)))
(patches
(search-patches "aux-files/python-bugwarrior/gitea-support.patch"))
@@ -57,26 +88,29 @@
python-tomli
python-pygobject
python-notify2
- python-pydantic-2.7.1
+ python-pydantic-2
+ python-google-api-client
+ python-google-auth-oauthlib
))
(native-inputs (list python-email-validator-2.1.1))
(home-page "http://github.com/ralphbean/bugwarrior")
(synopsis "Sync github, bitbucket, and trac issues with taskwarrior")
(description "Sync github, bitbucket, and trac issues with taskwarrior")
- (license #f)))
+ (license license:gpl3)))
(define-public python-email-validator-2.1.1
(package
(name "python-email-validator")
- (version "2.1.1")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "email_validator" version))
(sha256
- (base32 "112bhbxkwls2v0j5k6ir6iv6h3fc0n975vqydnz092d01dl702i0"))))
+ (base32 "0k7hm433xm9syxfq486zflxf7fqiljgv688480vxmgn48g9z7h0l"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-dnspython python-idna))
+ (native-inputs (list python-setuptools python-wheel))
(arguments
'( #:phases
(modify-phases %standard-phases
@@ -88,16 +122,7 @@
(description
"This package provides a robust email address syntax and deliverability
validation library.")
- (license #f)))
-
- (define-public python-pydantic-2.7.1
- (package
- (inherit python-pydantic)
- (name "python-email-validator")
- (inputs (modify-inputs (package-inputs python-pydantic)
- (prepend python-email-validator-2.1.1)))
- (version "2.1.1")
- ))
+ (license license:unlicense)))
(define-public python-taskw
(package
@@ -110,10 +135,14 @@
(sha256
(base32 "1pcbai69la53fjn2ahmni18zcgrhg34058q7a0mb7ag7ppwvs28i"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-kitchen python-dateutil python-pytz))
- (native-inputs (list python-pytest taskwarrior))
+ (propagated-inputs (list python-kitchen python-dateutil python-pytz taskwarrior python-setuptools python-wheel python-pytest))
+ (arguments
+ '( #:phases
+ (modify-phases %standard-phases
+ (delete 'check) ;Networking required for checks, so disable them
+ )))
(home-page "http://github.com/ralphbean/taskw")
(synopsis "Python bindings for your taskwarrior database")
(description "Python bindings for your taskwarrior database")
- (license #f)))
+ (license license:gpl3)))