summaryrefslogtreecommitdiffstats
path: root/aux-files
diff options
context:
space:
mode:
Diffstat (limited to 'aux-files')
-rw-r--r--aux-files/matrix-purple/fix-g_memdup.patch25
-rw-r--r--aux-files/python-bugwarrior/gitea-support.patch149
-rw-r--r--aux-files/stable-diffusion-cpp/vulkan-support.patch123
3 files changed, 291 insertions, 6 deletions
diff --git a/aux-files/matrix-purple/fix-g_memdup.patch b/aux-files/matrix-purple/fix-g_memdup.patch
new file mode 100644
index 0000000..d0ed6dc
--- /dev/null
+++ b/aux-files/matrix-purple/fix-g_memdup.patch
@@ -0,0 +1,25 @@
+From 2452ec47427f62a9a521742c4d46bceb073229db Mon Sep 17 00:00:00 2001
+From: msglm <msglm@techchud.xyz>
+Date: Sun, 19 Jan 2025 11:53:20 -0600
+Subject: [PATCH] g_memdup -> g_memdup2
+
+---
+ matrix-room.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/matrix-room.c b/matrix-room.c
+index 34ae48b..0d7bc06 100644
+--- a/matrix-room.c
++++ b/matrix-room.c
+@@ -671,7 +671,7 @@ static void _image_download_complete(MatrixConnectionData *ma,
+ }
+ if (is_known_image_type(content_type)) {
+ /* Excellent - something to work with */
+- int img_id = purple_imgstore_add_with_id(g_memdup(raw_body, raw_body_len),
++ int img_id = purple_imgstore_add_with_id(g_memdup2(raw_body, raw_body_len),
+ raw_body_len, NULL);
+ serv_got_chat_in(rid->conv->account->gc, g_str_hash(rid->room_id), rid->sender_display_name,
+ PURPLE_MESSAGE_RECV | PURPLE_MESSAGE_IMAGES,
+--
+2.46.0
+
diff --git a/aux-files/python-bugwarrior/gitea-support.patch b/aux-files/python-bugwarrior/gitea-support.patch
index 6c2c331..80ccb4b 100644
--- a/aux-files/python-bugwarrior/gitea-support.patch
+++ b/aux-files/python-bugwarrior/gitea-support.patch
@@ -1,7 +1,7 @@
From 6d7e50b5d1f7e79a685b08045cd91ea0b24f2154 Mon Sep 17 00:00:00 2001
From: wamsachel <wamsachel@gmail.com>
Date: Wed, 1 Apr 2020 22:27:52 +0000
-Subject: [PATCH 1/2] (WIP) Adding service support for Gitea
+Subject: [PATCH 1/8] (WIP) Adding service support for Gitea
Imported from https://github.com/GothenburgBitFactory/bugwarrior/pull/720
---
@@ -568,7 +568,7 @@ index c761a231..b5306da5 100644
From 80cd03d1ff85244f8a2c2beb37eab16af11e1adf Mon Sep 17 00:00:00 2001
From: msglm <msglm@techchud.xyz>
Date: Tue, 21 May 2024 04:21:35 -0500
-Subject: [PATCH 2/2] Add basic Gitea support
+Subject: [PATCH 2/8] Add basic Gitea support
Builds off PR #720 to add gitea integration to bugwarrior.
---
@@ -844,7 +844,7 @@ index a4c174c8..445846ff 100644
From 81b3fa0b47db93fb83a54c6727f5ee3c408797c5 Mon Sep 17 00:00:00 2001
From: msglm <msglm@techchud.xyz>
Date: Wed, 22 May 2024 20:59:54 -0500
-Subject: [PATCH 3/4] Add basic documentation
+Subject: [PATCH 3/8] Add basic documentation
mish-mash between the github and gitlab documentation with everything I
don't think is supported removed.
@@ -987,7 +987,7 @@ index 00000000..6ccf2308
From 1626a36c15013fc42e369cdc9ef98c23e10845c2 Mon Sep 17 00:00:00 2001
From: msglm <msglm@techchud.xyz>
Date: Wed, 22 May 2024 21:00:20 -0500
-Subject: [PATCH 4/4] Remove Six usage and clean the codebase
+Subject: [PATCH 4/8] Remove Six usage and clean the codebase
Suggestions from here are implemented
https://github.com/GothenburgBitFactory/bugwarrior/pull/1048#pullrequestreview-2070021239
@@ -1057,7 +1057,7 @@ index 445846ff..341ec617 100644
From 17b725774281e9742b786dbcbcf791f7f3dacf61 Mon Sep 17 00:00:00 2001
From: msglm <msglm@techchud.xyz>
Date: Thu, 23 May 2024 05:03:39 -0500
-Subject: [PATCH 5/6] Intake Critique and simplify
+Subject: [PATCH 5/8] Intake Critique and simplify
Remove user+pass auth, token only now.
Added issue API Querying for writing custom queries
@@ -1367,7 +1367,7 @@ index 341ec617..28a92e96 100644
From 3eb6e743c7ee4c7892525c05d880f5d05d3f8600 Mon Sep 17 00:00:00 2001
From: msglm <msglm@techchud.xyz>
Date: Thu, 23 May 2024 05:13:33 -0500
-Subject: [PATCH 6/6] Documentation for previous commit
+Subject: [PATCH 6/8] Documentation for previous commit
---
bugwarrior/docs/services/gitea.rst | 31 +++++++++++++++++++++++++++---
@@ -1424,3 +1424,140 @@ index 6ccf2308..19e0930a 100644
Provided UDA Fields
-------------------
+
+From 439c3f02338a43dcd0309fe297a706f0232a6138 Mon Sep 17 00:00:00 2001
+From: msglm <msglm@techchud.xyz>
+Date: Wed, 19 Feb 2025 03:32:02 -0600
+Subject: [PATCH 7/8] Update to modern standards
+
+---
+ bugwarrior/services/gitea.py | 37 +++++++++++++++---------------------
+ 1 file changed, 15 insertions(+), 22 deletions(-)
+
+diff --git a/bugwarrior/services/gitea.py b/bugwarrior/services/gitea.py
+index 28a92e96..8814633a 100644
+--- a/bugwarrior/services/gitea.py
++++ b/bugwarrior/services/gitea.py
+@@ -3,9 +3,9 @@
+ """Bugwarrior service support class for Gitea
+
+ Available classes:
+-- GiteaClient(ServiceClient): Constructs Gitea API strings
++- GiteaClient(Service): Constructs Gitea API strings
+ - GiteaIssue(Issue): TaskWarrior Interface
+-- GiteaService(IssueService): Engine for firing off requests
++- GiteaService(Issue): Engine for firing off requests
+
+ Todo:
+ * Add token support
+@@ -25,7 +25,7 @@
+ from jinja2 import Template
+
+ from bugwarrior import config
+-from bugwarrior.services import IssueService, Issue, ServiceClient
++from bugwarrior.services import Issue, Service, Client
+
+ log = logging.getLogger(__name__) # pylint: disable-msg=C0103
+
+@@ -62,7 +62,7 @@ def get(self, key, default=None, to_type=None):
+ return default
+
+
+-class GiteaClient(ServiceClient):
++class GiteaClient(Client):
+ """Builds Gitea API strings
+ Args:
+ host (str): remote gitea server
+@@ -263,8 +263,11 @@ class GiteaIssue(Issue):
+ @staticmethod
+ def _normalize_label_to_tag(label):
+ return re.sub(r'[^a-zA-Z0-9]', '_', label)
++ def get_tags(self):
++ labels = [label['name'] for label in self.record.get('labels', [])]
++ return self.get_tags_from_labels(labels)
+
+- def to_taskwarrior(self):
++ def to_taskwarrior(self) -> dict:
+ milestone = self.record['milestone']
+ if milestone:
+ milestone = milestone['title']
+@@ -302,31 +305,18 @@ def to_taskwarrior(self):
+ self.NAMESPACE: self.extra['namespace'],
+ self.STATE: self.record.get('state', '')
+ }
+- def get_tags(self):
+- labels = [label['name'] for label in self.record.get('labels', [])]
+- return self.get_tags_from_labels(labels)
+-
+- def get_default_description(self):
+- log.info('In get_default_description')
+- return self.build_default_description(
+- title=self.record['title'],
+- url=self.get_processed_url(self.record['url']),
+- number=self.record['number'],
+- cls=self.extra['type'],
+- )
+-
+
+ def get_default_description(self):
+ log.info('In get_default_description')
+ return self.build_default_description(
+ title=self.record['title'],
+- url=self.get_processed_url(self.record['url']),
++ url=self.record['url'],
+ number=self.record['number'],
+ cls=self.extra['type'],
+ )
+
+
+-class GiteaService(IssueService):
++class GiteaService(Service):
+ ISSUE_CLASS = GiteaIssue
+ CONFIG_SCHEMA = GiteaConfig
+ CONFIG_PREFIX = 'gitea'
+@@ -455,7 +445,7 @@ def annotations(self, tag, issue, issue_obj):
+ ) for c in comments)
+ annotations_result = self.build_annotations(
+ annotations,
+- issue_obj.get_processed_url(url))
++ url)
+ log.info('annotations: {}'.format(annotations_result))
+ return annotations_result
+
+@@ -573,6 +563,9 @@ def issues(self):
+ 'annotations': [issue['body']],
+ 'namespace': self.username,
+ }
+- issue_obj.update_extra(extra)
++ issue_obj.extra.update(extra)
+ yield issue_obj
+
++
++
++
+
+From db4c47837d15cb126cb97a97f72db061052db5ab Mon Sep 17 00:00:00 2001
+From: msglm <msglm@techchud.xyz>
+Date: Wed, 19 Feb 2025 03:34:16 -0600
+Subject: [PATCH 8/8] Do not yield on AttributeError
+
+Previously, when there is an AttributeError in a service, the service
+will return its issue object instead of a dictionary representation of
+the issue. This fixes it by raising an error if this happens.
+---
+ bugwarrior/collect.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bugwarrior/collect.py b/bugwarrior/collect.py
+index 8d435461..34af838a 100644
+--- a/bugwarrior/collect.py
++++ b/bugwarrior/collect.py
+@@ -100,7 +100,7 @@ def aggregate_issues(conf, main_section, debug):
+ log.error(f"Aborted [{target}] due to critical error.")
+ yield ('SERVICE FAILED', target)
+ continue
+- yield issue
++ raise
+
+ log.info("Done aggregating remote issues.")
+
diff --git a/aux-files/stable-diffusion-cpp/vulkan-support.patch b/aux-files/stable-diffusion-cpp/vulkan-support.patch
new file mode 100644
index 0000000..88f5fbf
--- /dev/null
+++ b/aux-files/stable-diffusion-cpp/vulkan-support.patch
@@ -0,0 +1,123 @@
+From 15553084e5d1a7d6abd3aac176bee95b0247c379 Mon Sep 17 00:00:00 2001
+From: sohzm <sohxm7@gmail.com>
+Date: Wed, 19 Jun 2024 04:08:18 +0530
+Subject: [PATCH] wip
+
+---
+ CMakeLists.txt | 7 +++++++
+ ggml | 2 +-
+ ggml_extend.hpp | 6 +++++-
+ model.cpp | 4 ++++
+ stable-diffusion.cpp | 6 +++++-
+ upscaler.cpp | 4 ++++
+ 6 files changed, 26 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 28a03fb..6b5679f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,6 +27,7 @@ option(SD_BUILD_EXAMPLES "sd: build examples" ${SD_STANDALONE})
+ option(SD_CUBLAS "sd: cuda backend" OFF)
+ option(SD_HIPBLAS "sd: rocm backend" OFF)
+ option(SD_METAL "sd: metal backend" OFF)
++option(SD_VULKAN "sd: vulkan backend" OFF)
+ option(SD_FLASH_ATTN "sd: use flash attention for x4 less memory usage" OFF)
+ option(SD_FAST_SOFTMAX "sd: x1.5 faster softmax, indeterministic (sometimes, same seed don't generate same image), cuda only" OFF)
+ option(SD_BUILD_SHARED_LIBS "sd: build shared libs" OFF)
+@@ -44,6 +45,12 @@ if(SD_METAL)
+ add_definitions(-DSD_USE_METAL)
+ endif()
+
++if (SD_VULKAN)
++ message("Use Vulkan as backend stable-diffusion")
++ set(GGML_VULKAN ON)
++ add_definitions(-DSD_USE_VULKAN)
++endif ()
++
+ if (SD_HIPBLAS)
+ message("Use HIPBLAS as backend stable-diffusion")
+ set(GGML_HIPBLAS ON)
+diff --git a/ggml b/ggml
+index 9d562d7..5653a19 160000
+--- a/ggml
++++ b/ggml
+@@ -1 +1 @@
+-Subproject commit 9d562d712513c77a4de44ad0428be62bc3f2a9cf
++Subproject commit 5653a195935ea3ac54652644c9daf154dbc1571b
+diff --git a/ggml_extend.hpp b/ggml_extend.hpp
+index dbe9303..1236996 100644
+--- a/ggml_extend.hpp
++++ b/ggml_extend.hpp
+@@ -32,6 +32,10 @@
+ #include "ggml-metal.h"
+ #endif
+
++#ifdef SD_USE_VULKAN
++#include "ggml-vulkan.h"
++#endif
++
+ #include "rng.hpp"
+ #include "util.h"
+
+@@ -588,7 +592,7 @@ __STATIC_INLINE__ struct ggml_tensor* ggml_nn_attention(struct ggml_context* ctx
+ struct ggml_tensor* k,
+ struct ggml_tensor* v,
+ bool mask = false) {
+-#if defined(SD_USE_FLASH_ATTENTION) && !defined(SD_USE_CUBLAS) && !defined(SD_USE_METAL)
++#if defined(SD_USE_FLASH_ATTENTION) && !defined(SD_USE_CUBLAS) && !defined(SD_USE_METAL) && !defined(SD_USE_VULKAN)
+ struct ggml_tensor* kqv = ggml_flash_attn(ctx, q, k, v, false); // [N * n_head, n_token, d_head]
+ #else
+ float d_head = (float)q->ne[0];
+diff --git a/model.cpp b/model.cpp
+index c4556a9..db8bae8 100644
+--- a/model.cpp
++++ b/model.cpp
+@@ -21,6 +21,10 @@
+ #include "ggml-metal.h"
+ #endif
+
++#ifdef SD_USE_VULKAN
++#include "ggml-vulkan.h"
++#endif
++
+ #define ST_HEADER_SIZE_LEN 8
+
+ uint64_t read_u64(uint8_t* buffer) {
+diff --git a/stable-diffusion.cpp b/stable-diffusion.cpp
+index 8e439d2..3521e76 100644
+--- a/stable-diffusion.cpp
++++ b/stable-diffusion.cpp
+@@ -154,13 +154,17 @@ class StableDiffusionGGML {
+ ggml_backend_metal_log_set_callback(ggml_log_callback_default, nullptr);
+ backend = ggml_backend_metal_init();
+ #endif
++#ifdef SD_USE_VULKAN
++ LOG_DEBUG("Using Vulkan backend");
++ backend = ggml_backend_vk_init();
++#endif
+
+ if (!backend) {
+ LOG_DEBUG("Using CPU backend");
+ backend = ggml_backend_cpu_init();
+ }
+ #ifdef SD_USE_FLASH_ATTENTION
+-#if defined(SD_USE_CUBLAS) || defined(SD_USE_METAL)
++#if defined(SD_USE_CUBLAS) || defined(SD_USE_METAL) || defined(SD_USE_VULKAN)
+ LOG_WARN("Flash Attention not supported with GPU Backend");
+ #else
+ LOG_INFO("Flash Attention enabled");
+diff --git a/upscaler.cpp b/upscaler.cpp
+index 0e3f95d..7623f9b 100644
+--- a/upscaler.cpp
++++ b/upscaler.cpp
+@@ -24,6 +24,10 @@ struct UpscalerGGML {
+ ggml_backend_metal_log_set_callback(ggml_log_callback_default, nullptr);
+ backend = ggml_backend_metal_init();
+ #endif
++#ifdef SD_USE_VULKAN
++ LOG_DEBUG("Using Vulkan backend");
++ backend = ggml_backend_vk_init(0);
++#endif
+
+ if (!backend) {
+ LOG_DEBUG("Using CPU backend");