summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--woeusb-ng.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/woeusb-ng.scm b/woeusb-ng.scm
new file mode 100644
index 0000000..72a73cf
--- /dev/null
+++ b/woeusb-ng.scm
@@ -0,0 +1,42 @@
+(define-module (woeusb-ng)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages wxwidgets)
+ #:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
+ #:use-module (guix build utils)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+)
+
+(define-public woeusb-ng
+ (package
+ (name "woeusb-ng")
+ (version "0.2.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "WoeUSB-ng" version))
+ (sha256
+ (base32 "18j6bshvxmbalhjlpwgw3400nghdfqgk4k232j695x1lp3l1lxkm"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-before 'build 'fix-installer
+ (lambda _
+ (substitute* "setup.py" ( (" post_install()") " #post_install()" ))))
+ )))
+ (propagated-inputs (list python-termcolor python-wxpython))
+ (home-page "https://github.com/WoeUSB/WoeUSB-ng")
+ (synopsis
+ "WoeUSB-ng is a simple tool that enable you to create your own usb stick windows installer from an iso image or a real DVD. This is a rewrite of original WoeUSB.")
+ (description
+ "@code{WoeUSB-ng} is a simple tool that enable you to create your own usb stick
+windows installer from an iso image or a real DVD. This is a rewrite of original
+@code{WoeUSB}.")
+ (license gpl3)))
+