summaryrefslogtreecommitdiffstats
path: root/stashley.scm
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2024-04-08 14:44:43 -0500
committermsglm <msglm@techchud.xyz>2024-04-08 14:44:43 -0500
commitc085c5788c932d4b515ba871493268b1bb9d9c24 (patch)
treeb9a602a3f5b5048dd64c58abd9c954e14e5e54ad /stashley.scm
parentb513dee983d319268c89966f9e22a64d6181097b (diff)
downloadguix-msglm-c085c5788c932d4b515ba871493268b1bb9d9c24.tar.gz
guix-msglm-c085c5788c932d4b515ba871493268b1bb9d9c24.tar.bz2
guix-msglm-c085c5788c932d4b515ba871493268b1bb9d9c24.zip
removed accidently added unfinished packages
Diffstat (limited to 'stashley.scm')
-rw-r--r--stashley.scm35
1 files changed, 20 insertions, 15 deletions
diff --git a/stashley.scm b/stashley.scm
index 14a941f..4b86195 100644
--- a/stashley.scm
+++ b/stashley.scm
@@ -1,20 +1,20 @@
(define-module (stashley)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) :prefix license:)
#:use-module (guix packages)
- #:use-module (guix build-system copy)
+ #:use-module (guix build-system pyproject)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
- #:use-module (gnu packages video)
- #:use-module (gnu packages admin)
+ #:use-module (gnu packages)
#:use-module (gnu packages wget)
+ #:use-module (gnu packages video)
#:use-module (gnu packages python-xyz)
- #:use-module (ipfs-archive-manager)
)
(define-public stashley
(package
(name "stashley")
- (version "1.1.1")
+ (version "2.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -23,22 +23,27 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0sbr01pwig0szcgjbzncgbs2c3xnshfrzhw9jhccmy453sblwrll"))))
- (build-system copy-build-system)
+ "0x7zb604b3v2b9n531i9x31zqdgbrry4sa18xb94766a0scid05n"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (delete 'sanity-check)
+ )))
(inputs
(list
- ipfs-archive-manager
yt-dlp
gallery-dl
- python-yq
- fdupes
wget
- python-yq))
- (arguments
- '(#:install-plan '(("stashley" "/bin/stashley"))))
+ python-tomli
+ python-tomli-w
+ sherlock
+ ))
(synopsis "Program using TOML files to archive personalities to IPFS")
(description
"Stashley is a program used for archiving personalities using
TOML files, and if IPFS is installed, pushing them to IPFS.")
(home-page "https://git.techchud.xyz/stashley/")
- (license agpl3)))
+ (license license:agpl3)))