summaryrefslogtreecommitdiffstats
path: root/stashley.scm
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2024-05-11 16:57:07 -0500
committermsglm <msglm@techchud.xyz>2024-05-11 16:57:07 -0500
commitae7079af301d73896c7af00f3a65d3976d356951 (patch)
tree8ee47c30fb84794575e5a72914e4be606d5abad2 /stashley.scm
parent7a5dac9003428c3240be3370b0ad9231e858b8df (diff)
downloadguix-msglm-ae7079af301d73896c7af00f3a65d3976d356951.tar.gz
guix-msglm-ae7079af301d73896c7af00f3a65d3976d356951.tar.bz2
guix-msglm-ae7079af301d73896c7af00f3a65d3976d356951.zip
add comedyGenerator; move stashley to python-xyz
Diffstat (limited to 'stashley.scm')
-rw-r--r--stashley.scm51
1 files changed, 0 insertions, 51 deletions
diff --git a/stashley.scm b/stashley.scm
deleted file mode 100644
index fae6097..0000000
--- a/stashley.scm
+++ /dev/null
@@ -1,51 +0,0 @@
-(define-module (stashley)
- #:use-module ((guix licenses) :prefix license:)
- #:use-module (guix packages)
- #:use-module (guix build-system pyproject)
- #:use-module (guix build-system python)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module (gnu packages)
- #:use-module (gnu packages wget)
- #:use-module (gnu packages video)
- #:use-module (gnu packages python-xyz)
- #:use-module (gnu packages python-build)
- #:use-module (sherlock)
- )
-
-(define-public stashley
- (package
- (name "stashley")
- (version "2.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.techchud.xyz/stashley")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1zrbw4b0jmczaf0dbp29vv2997n42l12nxwq4wji3zm9bwcgb4zg"))))
- (build-system pyproject-build-system)
- (arguments
- '(
- #:phases
- (modify-phases %standard-phases
- (delete 'check)
- (delete 'sanity-check)
- )))
- (inputs
- (list
- yt-dlp
- gallery-dl
- wget
- python-tomli
- python-tomli-w
- python-sherlock
- ))
- (synopsis "Program using TOML files to archive personalities to IPFS")
- (description
- "Stashley is a program used for archiving personalities using
- TOML files, and if IPFS is installed, pushing them to IPFS.")
- (home-page "https://git.techchud.xyz/stashley/")
- (license license:agpl3)))