summaryrefslogtreecommitdiffstats
path: root/sherlock.scm
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2024-07-06 23:10:17 -0500
committermsglm <msglm@techchud.xyz>2024-07-06 23:10:28 -0500
commit8d19b79834b413d9e77c237b015d8ffd85e8dbaa (patch)
treec5bea10edbbc9c63a6e6ec427a29d23c68c125de /sherlock.scm
parent36cff3a062c5fb443f390a37db042a1c5cf668ea (diff)
downloadguix-msglm-8d19b79834b413d9e77c237b015d8ffd85e8dbaa.tar.gz
guix-msglm-8d19b79834b413d9e77c237b015d8ffd85e8dbaa.tar.bz2
guix-msglm-8d19b79834b413d9e77c237b015d8ffd85e8dbaa.zip
use more up to date poetry version for sherlock
Diffstat (limited to 'sherlock.scm')
-rw-r--r--sherlock.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/sherlock.scm b/sherlock.scm
index e99c5b6..3168274 100644
--- a/sherlock.scm
+++ b/sherlock.scm
@@ -12,6 +12,7 @@
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages check)
#:use-module (gnu packages certs)
#:use-module (guix download)
@@ -92,12 +93,6 @@
))
(sha256
(base32 "0lb1r5fkwxm1zyxsax5aq3gp77gjz22i0agz6zyw5j9zrwb7c5g9"))
- (modules '((guix build utils)))
- (patches
- (search-patches "aux-files/sherlock/setuppy-support.patch"))
- (snippet
- '(begin
- (delete-file-recursively "images") #t))
))
(build-system pyproject-build-system)
(arguments
@@ -107,7 +102,7 @@
(delete 'sanity-check) ;we're going crazy, since sanity crashes.
)))
(native-inputs (list
- poetry
+ python-poetry-core
))
(propagated-inputs (list python-certifi
python-pandas
@@ -119,7 +114,7 @@
python-requests
python-requests-futures
python-stem))
- (home-page "https://sherlock-project.github.io/")
+ (home-page "https://github.com/sherlock-project/sherlock")
(synopsis
"Hunt down social media accounts by username across social networks.")
(description