summaryrefslogtreecommitdiffstats
path: root/sherlock.scm
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2025-04-04 05:26:58 -0500
committermsglm <msglm@techchud.xyz>2025-04-04 05:26:58 -0500
commit0b31d3e45aab39fb93dffbb3336deded5c96815c (patch)
tree18a3e87ac926b3d6c4593a1bea7fd95c5d9833e6 /sherlock.scm
parent6b96ffcc7152132d643509d72bb64a6d9c5f7deb (diff)
downloadguix-msglm-0b31d3e45aab39fb93dffbb3336deded5c96815c.tar.gz
guix-msglm-0b31d3e45aab39fb93dffbb3336deded5c96815c.tar.bz2
guix-msglm-0b31d3e45aab39fb93dffbb3336deded5c96815c.zip
fix python-requests-future and python-torrequersts not having setuptools and build
Diffstat (limited to 'sherlock.scm')
-rw-r--r--sherlock.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/sherlock.scm b/sherlock.scm
index a6f787a..2b4875a 100644
--- a/sherlock.scm
+++ b/sherlock.scm
@@ -40,6 +40,8 @@
python-pytest-cov
;python-pytest-network
python-readme-renderer
+ python-setuptools
+ python-wheel
python-twine))
(home-page "https://github.com/ross/requests-futures")
(synopsis "Asynchronous Python HTTP for Humans.")
@@ -73,7 +75,10 @@
(sha256
(base32 "10mf9p6r4wwk9m50jh5bpmvsnymkmn3wfqs30dx8vagx7zmd8i9p"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-pysocks python-requests python-stem))
+ (propagated-inputs (list python-pysocks python-requests python-stem
+ python-setuptools
+ python-wheel
+ ))
(home-page "http://github.com/erdiaker/torrequest")
(synopsis "A simple interface for HTTP(s) requests over Tor")
(description