summaryrefslogtreecommitdiffstats
path: root/rclip.scm
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2024-03-27 14:29:13 -0500
committermsglm <msglm@techchud.xyz>2024-03-27 14:29:13 -0500
commit0929cd80303bbc661912567235d18e656c8038b0 (patch)
tree310a9801d46728d2db7f3f5f9e0a1b682dad618b /rclip.scm
parentaefe43b6451fa2c1ac1ae72938c2133e95335f14 (diff)
downloadguix-msglm-0929cd80303bbc661912567235d18e656c8038b0.tar.gz
guix-msglm-0929cd80303bbc661912567235d18e656c8038b0.tar.bz2
guix-msglm-0929cd80303bbc661912567235d18e656c8038b0.zip
fix recursive imports in rclip
Diffstat (limited to 'rclip.scm')
-rw-r--r--rclip.scm86
1 files changed, 50 insertions, 36 deletions
diff --git a/rclip.scm b/rclip.scm
index 76f3db9..5d472a4 100644
--- a/rclip.scm
+++ b/rclip.scm
@@ -33,7 +33,7 @@
(sha256
(base32 "18imz7hm6a6n94r2kyaw5rjvs8dk22szwdagx0p5gap8x80l0yps"))))
(build-system pyproject-build-system)
- (inputs (list poetry-1.8.2))
+ (native-inputs (list poetry-1.3))
(home-page "https://github.com/python-poetry/poetry-core")
(synopsis "Poetry PEP 517 Build Backend")
(description "Poetry PEP 517 Build Backend")
@@ -76,43 +76,57 @@
(define-public poetry-1.8.2
(package
+ (inherit poetry)
(name "poetry")
(version "1.8.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "poetry" version))
- (sha256
- (base32 "0wyb55x6izlhka23zlqqrh23f1f62d7kl7q2w71lfihh70wfpk29"))))
- (build-system pyproject-build-system)
- (propagated-inputs (list
- python-cachecontrol
- python-cleo
- python-crashtest
- python-dulwich
- python-fastjsonschema
- python-importlib-metadata
- python-installer
- python-keyring
- python-packaging
- python-pexpect
- python-pkginfo
- python-platformdirs
- python-poetry-core-1.9.0
- poetry-plugin-export
- python-pyproject-hooks
- python-requests
- python-requests-toolbelt
- python-shellingham
- python-tomli
- python-tomlkit
- python-trove-classifiers
- python-virtualenv
- python-xattr))
- (home-page "https://python-poetry.org/")
- (synopsis "Python dependency management and packaging made easy.")
- (description "Python dependency management and packaging made easy.")
- (license license:expat)))
+ ))
+
+(define-public poetry-1.3
+ (package
+ (inherit poetry)
+ (name "poetry")
+ (version "1.3")
+ ))
+
+;(define-public poetry-1.8.2
+; (package
+; (name "poetry")
+; (version "1.8.2")
+; (source
+; (origin
+; (method url-fetch)
+; (uri (pypi-uri "poetry" version))
+; (sha256
+; (base32 "0wyb55x6izlhka23zlqqrh23f1f62d7kl7q2w71lfihh70wfpk29"))))
+; (build-system pyproject-build-system)
+; (propagated-inputs (list
+; python-cachecontrol
+; python-cleo
+; python-crashtest
+; python-dulwich
+; python-fastjsonschema
+; python-importlib-metadata
+; python-installer
+; python-keyring
+; python-packaging
+; python-pexpect
+; python-pkginfo
+; python-platformdirs
+; python-poetry-core
+; poetry-plugin-export
+; python-pyproject-hooks
+; python-requests
+; python-requests-toolbelt
+; python-shellingham
+; python-tomli
+; python-tomlkit
+; python-trove-classifiers
+; python-virtualenv
+; python-xattr))
+; (home-page "https://python-poetry.org/")
+; (synopsis "Python dependency management and packaging made easy.")
+; (description "Python dependency management and packaging made easy.")
+; (license license:expat)))