summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2024-04-08 14:46:01 -0500
committermsglm <msglm@techchud.xyz>2024-04-08 14:46:01 -0500
commit95ac4f8f8fb47c5785954584d6c15737abe8f492 (patch)
treea463d9aa488f1054b4e17f00d9aca5dc7d677ff2
parentc085c5788c932d4b515ba871493268b1bb9d9c24 (diff)
downloadguix-msglm-95ac4f8f8fb47c5785954584d6c15737abe8f492.tar.gz
guix-msglm-95ac4f8f8fb47c5785954584d6c15737abe8f492.tar.bz2
guix-msglm-95ac4f8f8fb47c5785954584d6c15737abe8f492.zip
remove more unused stuff
-rw-r--r--aux-files/archivenow/fixsetup.patch27
-rw-r--r--aux-files/localai/.gitmodule0
-rw-r--r--butler.scm95
3 files changed, 0 insertions, 122 deletions
diff --git a/aux-files/archivenow/fixsetup.patch b/aux-files/archivenow/fixsetup.patch
deleted file mode 100644
index d66f82e..0000000
--- a/aux-files/archivenow/fixsetup.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 4e8b8c9447654656fe9f7a857611b0837f250e9b Mon Sep 17 00:00:00 2001
-From: Anonymous <anonymous@example.org>
-Date: Fri, 5 Apr 2024 22:17:53 -0500
-Subject: [PATCH] include archivebox.py in setup
-
----
- setup.py | 6 +-----
- 1 file changed, 1 insertion(+), 5 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index b62adcd..ab6528b 100644
---- a/setup.py
-+++ b/setup.py
-@@ -37,9 +37,5 @@ setup(
- 'templates/*.*',
- 'static/*.*'
- ]
-- },
-- entry_points='''
-- [console_scripts]
-- archivenow=archivenow.archivenow:args_parser
-- '''
-+ }
- )
---
-2.41.0
-
diff --git a/aux-files/localai/.gitmodule b/aux-files/localai/.gitmodule
deleted file mode 100644
index e69de29..0000000
--- a/aux-files/localai/.gitmodule
+++ /dev/null
diff --git a/butler.scm b/butler.scm
deleted file mode 100644
index 3fc4174..0000000
--- a/butler.scm
+++ /dev/null
@@ -1,95 +0,0 @@
-(define-module (butler)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix build-system go)
- #:use-module (guix git-download)
- #:use-module (guix build utils)
- #:use-module (guix gexp)
- #:use-module (golang)
- #:use-module (gnu packages golang)
- #:use-module (gnu packages image)
- #:use-module (gnu packages tls)
- )
-(define-public go-github-com-itchio-butler
- (package
- (name "go-github-com-itchio-butler")
- (version "15.21.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/itchio/butler")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "14wcirxj5xcv60whvd7k8xcky0h2z8ym7gkhfb58vh3pfjcr5j5x"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/itchio/butler"))
- (propagated-inputs `(
- ("crawshaw.io/sqlite" ,go-crawshaw-io-sqlite)
- ("github.com/burntsushi/toml" ,go-github-com-burntsushi-toml)
- ("github.com/arbovm/levenshtein" ,go-github-com-arbovm-levenshtein)
- ("github.com/dchest/safefile" ,go-github-com-dchest-safefile)
- ("github.com/dustinkirkland/golang-petname" ,go-github-com-dustinkirkland-golang-petname)
- ("github.com/efarrer/iothrottler" ,go-github-com-efarrer-iothrottler)
- ("github.com/fatih/color" ,go-github-com-fatih-color)
- ("github.com/fatih/structtag" ,go-github-com-fatih-structtag)
- ("github.com/getlantern/mtime" ,go-github-com-getlantern-mtime)
- ("github.com/getlantern/ops" ,go-github-com-getlantern-ops)
- ("github.com/go-ole/go-ole" ,go-github-com-go-ole-go-ole)
- ("github.com/go-ozzo/ozzo-validation" ,go-github-com-go-ozzo-ozzo-validation)
- ("github.com/golang/protobuf" ,go-google-golang-org-protobuf)
- ("github.com/google/gops" ,go-github-com-google-gops)
- ("github.com/google/uuid" ,go-github-com-google-uuid)
- ("github.com/helloeave/json" ,go-github-com-helloeave-json)
- ("github.com/itchio/arkive" ,go-github-com-itchio-arkive)
- ("github.com/itchio/boar" ,go-github-com-itchio-boar)
- ("github.com/itchio/dash" ,go-github-com-itchio-dash)
- ("github.com/itchio/elefant" ,go-github-com-itchio-elefant)
- ("github.com/itchio/go-itchio" ,go-github-com-itchio-go-itchio)
- ("github.com/itchio/hades" ,go-github-com-itchio-hades)
- ("github.com/itchio/headway" ,go-github-com-itchio-headway)
- ("github.com/itchio/httpkit" ,go-github-com-itchio-httpkit)
- ("github.com/itchio/hush" ,go-github-com-itchio-hush)
- ("github.com/itchio/intact" ,go-github-com-itchio-intact)
- ("github.com/itchio/lake" ,go-github-com-itchio-lake)
- ("github.com/itchio/mitch" ,go-github-com-itchio-mitch)
- ("github.com/itchio/ox" ,go-github-com-itchio-ox)
- ("github.com/itchio/pelican" ,go-github-com-itchio-pelican)
- ("github.com/itchio/savior" ,go-github-com-itchio-savior)
- ("github.com/itchio/screw" ,go-github-com-itchio-screw)
- ("github.com/itchio/smaug" ,go-github-com-itchio-smaug)
- ("github.com/itchio/spellbook" ,go-github-com-itchio-spellbook)
- ("github.com/itchio/wharf" ,go-github-com-itchio-wharf)
- ("github.com/itchio/wizardry" ,go-github-com-itchio-wizardry)
- ("github.com/kballard/go-shellquote" ,go-github-com-kballard-go-shellquote)
- ("github.com/klauspost/compress" ,go-github-com-klauspost-compress)
- ("github.com/mattn/go-colorable" ,go-github-com-mattn-go-colorable)
- ("github.com/mattn/go-runewidth" ,go-github-com-mattn-go-runewidth)
- ("github.com/mitchellh/mapstructure" ,go-github-com-mitchellh-mapstructure)
- ("github.com/natefinch/npipe" ,go-github-com-natefinch-npipe)
- ("github.com/nightlyone/lockfile" ,go-github-com-nightlyone-lockfile)
- ("github.com/olekukonko/tablewriter" ,go-github-com-olekukonko-tablewriter)
- ("github.com/pkg/errors" ,go-github-com-pkg-errors)
- ("github.com/russross/blackfriday" ,go-github-com-russross-blackfriday)
- ("github.com/scjalliance/comshim" ,go-github-com-scjalliance-comshim)
- ("github.com/shurcool/sanitized_anchor_name" ,go-github-com-shurcool-sanitized-anchor-name)
- ("github.com/skratchdot/open-golang" ,go-github-com-skratchdot-open-golang)
- ("github.com/stretchr/testify" ,go-github-com-stretchr-testify)
- ("golang.org/x/crypto" ,go-golang-org-x-crypto)
- ("golang.org/x/net" ,go-golang-org-x-net)
- ("golang.org/x/sync" ,go-golang-org-x-sync)
- ("golang.org/x/sys" ,go-golang-org-x-sys)
- ("golang.org/x/text" ,go-golang-org-x-text)
- ("golang.org/x/time" ,go-golang-org-x-time)
- ("google.golang.org/protobuf" ,go-github-com-golang-protobuf-proto)
- ("gopkg.in/alecthomas/kingpin.v2" ,go-gopkg-in-alecthomas-kingpin-v2)
- ("gopkg.in/natefinch/npipe.v2" ,go-gopkg-in-natefinch-npipe-v2)
- ("gopkg.in/yaml.v3" ,go-gopkg-in-yaml-v3)
- ("xorm.io/builder" ,go-xorm-io-builder)
- ))
- (home-page "https://github.com/itchio/butler")
- (synopsis "butler")
- (description "butler is - all by itself.")
- (license expat)))