summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2025-01-19 05:10:26 -0600
committermsglm <msglm@techchud.xyz>2025-01-19 05:10:26 -0600
commit6c2fabf1f384a92e921c90cf07c94d09c39a65ee (patch)
tree3e6542d346fdbb58b7e313489900f532f2abfa50
parent7e23a241bf598cdea0b6546416a8d44b0b7cbb4d (diff)
downloadguix-msglm-6c2fabf1f384a92e921c90cf07c94d09c39a65ee.tar.gz
guix-msglm-6c2fabf1f384a92e921c90cf07c94d09c39a65ee.tar.bz2
guix-msglm-6c2fabf1f384a92e921c90cf07c94d09c39a65ee.zip
Fix python email validator
-rw-r--r--bugwarrior.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/bugwarrior.scm b/bugwarrior.scm
index e192602..0e21bda 100644
--- a/bugwarrior.scm
+++ b/bugwarrior.scm
@@ -24,7 +24,7 @@
(define-public python-bugwarrior
(package
(name "python-bugwarrior")
- (version "71efc97435a442646782dcb0979df43f69ce955d")
+ (version "1bef94c3ec29c7d1b33035dc795544da6a49fb3b")
(source
(origin
(method git-fetch)
@@ -32,7 +32,7 @@
(url "https://github.com/GothenburgBitFactory/bugwarrior.git")
(commit version)))
(sha256
- (base32 "0d22av15dyan6yzhqxx01sf45i2fnk1i92wyh9hahfhmv3gawnj1"))
+ (base32 "1y7qkyzd53yg472d2gl7kxgw2yrikmd17iw31zwvidfsf01p3hwh"))
(modules '((guix build utils)))
(patches
(search-patches "aux-files/python-bugwarrior/gitea-support.patch"))
@@ -68,15 +68,16 @@
(define-public python-email-validator-2.1.1
(package
(name "python-email-validator")
- (version "2.1.1")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "email_validator" version))
(sha256
- (base32 "112bhbxkwls2v0j5k6ir6iv6h3fc0n975vqydnz092d01dl702i0"))))
+ (base32 "0k7hm433xm9syxfq486zflxf7fqiljgv688480vxmgn48g9z7h0l"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-dnspython python-idna))
+ (native-inputs (list python-setuptools python-wheel))
(arguments
'( #:phases
(modify-phases %standard-phases
@@ -110,8 +111,12 @@
(sha256
(base32 "1pcbai69la53fjn2ahmni18zcgrhg34058q7a0mb7ag7ppwvs28i"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-kitchen python-dateutil python-pytz))
- (native-inputs (list python-pytest taskwarrior))
+ (propagated-inputs (list python-kitchen python-dateutil python-pytz taskwarrior python-setuptools python-wheel python-pytest))
+ (arguments
+ '( #:phases
+ (modify-phases %standard-phases
+ (delete 'check) ;Networking required for checks, so disable them
+ )))
(home-page "http://github.com/ralphbean/taskw")
(synopsis "Python bindings for your taskwarrior database")
(description "Python bindings for your taskwarrior database")