summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2025-01-11 19:22:29 -0600
committermsglm <msglm@techchud.xyz>2025-01-11 19:22:29 -0600
commit3bc008c3f7b7f83c19b4963d3e0f5c572bac7670 (patch)
treed3dcd3c66d91a7c35e7d57842b098788a4a91b16
parent947a9000c31a15f7e2f22b156a23d2b4b870e7f0 (diff)
downloadguix-msglm-3bc008c3f7b7f83c19b4963d3e0f5c572bac7670.tar.gz
guix-msglm-3bc008c3f7b7f83c19b4963d3e0f5c572bac7670.tar.bz2
guix-msglm-3bc008c3f7b7f83c19b4963d3e0f5c572bac7670.zip
update stashley
-rw-r--r--python-xyz.scm31
1 files changed, 28 insertions, 3 deletions
diff --git a/python-xyz.scm b/python-xyz.scm
index 73cb686..5bf0c93 100644
--- a/python-xyz.scm
+++ b/python-xyz.scm
@@ -12,6 +12,7 @@
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-science)
#:use-module (sherlock)
)
(define-public comedyGenerator
@@ -38,7 +39,7 @@
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((ffmpeg (string-append (assoc-ref inputs "ffmpeg") "/bin" )))
(wrap-program (string-append (assoc-ref outputs "out") "/bin/comedyGenerator")
- `("PATH" ":" prefix ,(list ffmpeg) ) ))))
+ `("PATH" ":" prefix ,(list ffmpeg) ) ))))
)))
(inputs
@@ -57,7 +58,7 @@
(define-public stashley
(package
(name "stashley")
- (version "2.0.2")
+ (version "2.0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -66,7 +67,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "1rdzgf6cynnmyy3fwkbyvffpz7vkqsa2isp1dblrqas0arqgplqh"))))
+ "01pih5d142a1vsga69kgwx740j53wzad399vbbl77ks5nyx65jpk"))))
(build-system pyproject-build-system)
(arguments
'(
@@ -90,3 +91,27 @@
TOML files, and if IPFS is installed, pushing them to IPFS.")
(home-page "https://git.techchud.xyz/stashley/")
(license license:agpl3)))
+(define-public python-imagehash
+ (package
+ (name "python-imagehash")
+ (version "4.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ImageHash" version))
+ (sha256
+ (base32 "0w5ay3dblgn0ijg4mwmmq13a759by1bakh6q7pmmnn70z6vx2f3h"))))
+ (arguments
+ '( #:phases
+ (modify-phases %standard-phases
+ (delete 'check) ;Networking required for checks, so disable them
+ )))
+
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy python-pillow python-pywavelets
+ python-scipy))
+ (home-page "https://github.com/JohannesBuchner/imagehash")
+ (synopsis "Image Hashing library")
+ (description "Image Hashing library.")
+ (license #f)))
+