summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2024-07-18 09:21:01 -0500
committermsglm <msglm@techchud.xyz>2024-07-18 09:21:01 -0500
commit0cf07cdc07ba76ad6ba2fc1b5a89a846d41c7590 (patch)
tree48429761dddc0e1dcd819a906b5503b024d96980
parent5b01aef84434c6e0b1c56c9447b2096b163de77c (diff)
downloadguix-msglm-0cf07cdc07ba76ad6ba2fc1b5a89a846d41c7590.tar.gz
guix-msglm-0cf07cdc07ba76ad6ba2fc1b5a89a846d41c7590.tar.bz2
guix-msglm-0cf07cdc07ba76ad6ba2fc1b5a89a846d41c7590.zip
update stable-diffusion-cpp
-rw-r--r--machinelearning.scm243
1 files changed, 221 insertions, 22 deletions
diff --git a/machinelearning.scm b/machinelearning.scm
index 7c6d949..634414b 100644
--- a/machinelearning.scm
+++ b/machinelearning.scm
@@ -83,13 +83,13 @@
(define-public python-rclip
(package
(name "rclip")
- (version "1.8.9")
+ (version "1.10.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rclip" version))
(sha256
- (base32 "02glbbvw3ijlnylvasnqms0rnd4z8pdc14iyqn921b8ac4mkkdki"))))
+ (base32 "05cv5hp63x6ym12s1a5lb7najjyzrqk40rvmj8x2y32hxsf6ampn"))))
(build-system pyproject-build-system)
(native-inputs (list python-poetry-core-1.9.0))
(propagated-inputs (list python-open-clip-torch
@@ -341,7 +341,7 @@
(define-public stable-diffusion-cpp
(package
(name "stable-diffusion-cpp")
- (version "48bcce493f45a11d9d5a4c69943d03ff919d748f")
+ (version "9c51d8787f78ef1bd0ead1e8f48b766d7ee7484d")
(source
(origin
(method git-fetch)
@@ -352,7 +352,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "1sx0y3b2bz9b5nqmav4g0hrsxinih3scyywy3zam8ywamcfpvww1"))))
+ "0rcnlrsbhnfhfz2pzn8gxnnpdyz03z8ds0wq5xfbgc86hmg0v286"))))
(build-system cmake-build-system)
(inputs (list openblas))
(arguments
@@ -360,7 +360,7 @@
#:tests? #f
;#:cmake "--config Release"
;#:configure-flags (list "-DSD_CUBLAS=ON -DGGML_OPENBLAS=ON --config Release")
- #:configure-flags (list "-DGGML_OPENBLAS=ON --config Release")
+ #:configure-flags (list "-DGGML_OPENBLAS=ON -DSD_FLASH_ATTN=ON --config Release")
)
)
(home-page "https://github.com/leejet/stable-diffusion.cpp")
@@ -368,7 +368,42 @@
(description "Inference of Stable Diffusion in pure C/C++")
(license license:expat)))
-
+(define-public bark-cpp
+ (package
+ (name "bark-cpp")
+ (version "03d70997620ab4d1130be68ef2ab3c763ba09576")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PABannier/bark.cpp.git")
+ (recursive? #t)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02s3nwpbq87r3l11bm2psc9lnra650rf87659kwx41p6kzsl536m"))))
+ (build-system cmake-build-system)
+ (inputs (list openblas))
+ (arguments
+ '(
+ #:tests? #f
+ #:configure-flags (list "-DGGML_OPENBLAS=ON --config Release")
+ ;#:phases
+ ;(modify-phases %standard-phases
+ ; (add-after 'install 'install-main
+ ; (lambda _
+ ; (with-directory-excursion (string-append #$output "/bin")
+ ; ;(symlink "main" "bark")
+ ; (symlink "server" "bark-server")
+ ; )
+ ; )))
+ )
+ )
+ (home-page "https://github.com/PABannier/bark.cpp")
+ (synopsis "Real-time realistic multilingual text-to-speech generation to the community.")
+ (description "With bark.cpp, our goal is to bring real-time realistic multilingual text-to-speech generation to the community.")
+ (license license:expat)))
(define-public clip-cpp
(package
@@ -427,23 +462,187 @@
)))))
(inputs
`(
- ("python", python)
- ("openblas", openblas)
-; ("ursearch"
-; ,(origin
-; (method git-fetch)
-; (uri (git-reference
-; (url "https://github.com/unum-cloud/usearch")
-; (recursive? #t)
-; (commit "v2.11.4")))
-; (sha256
-; (base32 "0l4gm6z5dal3146izqs7x82yf3sh4bsfwa9rkmnm2m4yc2snfbhp"))
-; )
-; )))
-)
-)
-; (native-inputs (list git-minimal))
+ ("python", python)
+ ("openblas", openblas)
+ ; ("ursearch"
+ ; ,(origin
+ ; (method git-fetch)
+ ; (uri (git-reference
+ ; (url "https://github.com/unum-cloud/usearch")
+ ; (recursive? #t)
+ ; (commit "v2.11.4")))
+ ; (sha256
+ ; (base32 "0l4gm6z5dal3146izqs7x82yf3sh4bsfwa9rkmnm2m4yc2snfbhp"))
+ ; )
+ ; )))
+ )
+ )
+ ; (native-inputs (list git-minimal))
(home-page "https://github.com/leejet/stable-diffusion.cpp")
(synopsis "Inference of Stable Diffusion in pure C/C++")
(description "Inference of Stable Diffusion in pure C/C++")
(license license:expat)))
+
+(define-public python-clip-interrogator
+ (package
+ (name "python-clip-interrogator")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "clip-interrogator" version))
+ (sha256
+ (base32 "14qn8bprpqg3nfgiki73n1cnwx6yg4qkw27ph4c1i5lvzrr27577"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-accelerate
+ python-open-clip-torch
+ python-pillow
+ python-requests
+ python-safetensors
+ python-pytorch
+ python-torchvision
+ python-tqdm
+ python-transformers))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/pharmapsychotic/clip-interrogator")
+ (synopsis "Generate a prompt from an image")
+ (description "Generate a prompt from an image.")
+ (license license:expat)))
+
+(define-public python-accelerate
+ (package
+ (name "python-accelerate")
+ (version "0.32.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "accelerate" version))
+ (sha256
+ (base32 "0xyijblpfsw8xhg4zz2kgdvl8d8nlgal52yrkx7hvk9p0bzsr69r"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-huggingface-hub
+ python-numpy
+ python-packaging
+ python-psutil
+ python-pyyaml
+ python-safetensors
+ python-pytorch))
+ (native-inputs (list python-bitsandbytes
+ python-black
+ python-comet-ml
+ python-datasets
+ python-diffusers
+ python-dvclive
+ python-evaluate
+ python-hf-doc-builder
+ python-parameterized
+ python-pytest
+ python-pytest-subtests
+ python-pytest-xdist
+ python-rich
+ python-ruff
+ python-scikit-learn
+ python-scipy
+ python-tensorboard
+ python-timm
+ python-torchpippy
+ python-tqdm
+ python-transformers
+ python-wandb))
+ (home-page "https://github.com/huggingface/accelerate")
+ (synopsis "Accelerate")
+ (description "Accelerate.")
+ (license #f)))
+
+(define-public python-transformers
+ (package
+ (name "python-transformers")
+ (version "4.42.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "transformers" version))
+ (sha256
+ (base32 "1szp60sbxc6qjav7g8pa3k2169wxc6j4xjfbcm9182aqyhzqffbm"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-filelock
+ python-huggingface-hub
+ python-numpy
+ python-packaging
+ python-pyyaml
+ python-regex
+ python-requests
+ python-safetensors
+ python-tokenizers
+ python-tqdm))
+ (native-inputs (list python-accelerate
+ python-av
+ python-beautifulsoup4
+ python-codecarbon
+ python-cookiecutter
+ python-datasets
+ python-decord
+ python-deepspeed
+ python-dill
+ python-evaluate
+ python-faiss-cpu
+ python-flax
+ python-fugashi
+ python-gitpython
+ python-ipadic
+ python-isort
+ python-jax
+ python-jaxlib
+ python-kenlm
+ python-keras-nlp
+ python-librosa
+ python-nltk
+ python-onnxconverter-common
+ python-onnxruntime
+ python-onnxruntime-tools
+ python-optax
+ python-optuna
+ python-parameterized
+ python-phonemizer
+ python-pillow
+ python-protobuf
+ python-psutil
+ python-pyctcdecode
+ python-pydantic
+ python-pytest
+ python-pytest-rich
+ python-pytest-timeout
+ python-pytest-xdist
+ python-ray
+ python-rhoknp
+ python-rjieba
+ python-rouge-score
+ python-ruff
+ python-sacrebleu
+ python-sacremoses
+ python-scikit-learn
+ python-scipy
+ python-sentencepiece
+ python-sigopt
+ python-sudachidict-core
+ python-sudachipy
+ python-tensorboard
+ python-tensorflow
+ python-tensorflow-text
+ python-tf2onnx
+ python-timeout-decorator
+ python-timm
+ python-tokenizers
+ python-torch
+ python-torchaudio
+ python-torchvision
+ python-unidic
+ python-unidic-lite
+ python-urllib3))
+ (home-page "https://github.com/huggingface/transformers")
+ (synopsis
+ "State-of-the-art Machine Learning for JAX, PyTorch and TensorFlow")
+ (description
+ "State-of-the-art Machine Learning for JAX, @code{PyTorch} and @code{TensorFlow}.")
+ (license #f)))
+