summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authormsglm <msglm@techchud.xyz>2024-03-18 22:36:49 -0500
committermsglm <msglm@techchud.xyz>2024-03-18 22:36:49 -0500
commit6d1e2f05f1c81f56951a2e890115b8e8bfb37e80 (patch)
tree1cb432a60bb35eaabd0b6c0c4bfb698ae32d7313 /setup.py
parent6bdb959afa2c04d1054eba6f1a1a695b2061bf79 (diff)
downloadstashley-6d1e2f05f1c81f56951a2e890115b8e8bfb37e80.tar.gz
stashley-6d1e2f05f1c81f56951a2e890115b8e8bfb37e80.tar.bz2
stashley-6d1e2f05f1c81f56951a2e890115b8e8bfb37e80.zip
skeleton of a rewrite
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..97abf83
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,11 @@
+from setuptools import setup
+
+setup(
+ name='stashley',
+ version='2.0',
+ description='a program used for archiving personalities using TOML files',
+ author='msglm',
+ author_email='msglm@techchud.xyz',
+ packages=['src'], #same as name
+ install_requires=['yt-dlp', 'gallery-dl'], #external packages as dependencies
+ )