summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--aux-files/archivenow/fixsetup.patch27
-rw-r--r--aux-files/localai/.gitmodule0
-rw-r--r--butler.scm95
-rw-r--r--golang.scm22
-rw-r--r--prismlauncher-gpu.scm4
-rw-r--r--stablediffusion.scm2
-rw-r--r--stashley.scm35
7 files changed, 145 insertions, 40 deletions
diff --git a/aux-files/archivenow/fixsetup.patch b/aux-files/archivenow/fixsetup.patch
new file mode 100644
index 0000000..d66f82e
--- /dev/null
+++ b/aux-files/archivenow/fixsetup.patch
@@ -0,0 +1,27 @@
+From 4e8b8c9447654656fe9f7a857611b0837f250e9b Mon Sep 17 00:00:00 2001
+From: Anonymous <anonymous@example.org>
+Date: Fri, 5 Apr 2024 22:17:53 -0500
+Subject: [PATCH] include archivebox.py in setup
+
+---
+ setup.py | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index b62adcd..ab6528b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -37,9 +37,5 @@ setup(
+ 'templates/*.*',
+ 'static/*.*'
+ ]
+- },
+- entry_points='''
+- [console_scripts]
+- archivenow=archivenow.archivenow:args_parser
+- '''
++ }
+ )
+--
+2.41.0
+
diff --git a/aux-files/localai/.gitmodule b/aux-files/localai/.gitmodule
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/aux-files/localai/.gitmodule
diff --git a/butler.scm b/butler.scm
new file mode 100644
index 0000000..3fc4174
--- /dev/null
+++ b/butler.scm
@@ -0,0 +1,95 @@
+(define-module (butler)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix build-system go)
+ #:use-module (guix git-download)
+ #:use-module (guix build utils)
+ #:use-module (guix gexp)
+ #:use-module (golang)
+ #:use-module (gnu packages golang)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages tls)
+ )
+(define-public go-github-com-itchio-butler
+ (package
+ (name "go-github-com-itchio-butler")
+ (version "15.21.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/itchio/butler")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14wcirxj5xcv60whvd7k8xcky0h2z8ym7gkhfb58vh3pfjcr5j5x"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/itchio/butler"))
+ (propagated-inputs `(
+ ("crawshaw.io/sqlite" ,go-crawshaw-io-sqlite)
+ ("github.com/burntsushi/toml" ,go-github-com-burntsushi-toml)
+ ("github.com/arbovm/levenshtein" ,go-github-com-arbovm-levenshtein)
+ ("github.com/dchest/safefile" ,go-github-com-dchest-safefile)
+ ("github.com/dustinkirkland/golang-petname" ,go-github-com-dustinkirkland-golang-petname)
+ ("github.com/efarrer/iothrottler" ,go-github-com-efarrer-iothrottler)
+ ("github.com/fatih/color" ,go-github-com-fatih-color)
+ ("github.com/fatih/structtag" ,go-github-com-fatih-structtag)
+ ("github.com/getlantern/mtime" ,go-github-com-getlantern-mtime)
+ ("github.com/getlantern/ops" ,go-github-com-getlantern-ops)
+ ("github.com/go-ole/go-ole" ,go-github-com-go-ole-go-ole)
+ ("github.com/go-ozzo/ozzo-validation" ,go-github-com-go-ozzo-ozzo-validation)
+ ("github.com/golang/protobuf" ,go-google-golang-org-protobuf)
+ ("github.com/google/gops" ,go-github-com-google-gops)
+ ("github.com/google/uuid" ,go-github-com-google-uuid)
+ ("github.com/helloeave/json" ,go-github-com-helloeave-json)
+ ("github.com/itchio/arkive" ,go-github-com-itchio-arkive)
+ ("github.com/itchio/boar" ,go-github-com-itchio-boar)
+ ("github.com/itchio/dash" ,go-github-com-itchio-dash)
+ ("github.com/itchio/elefant" ,go-github-com-itchio-elefant)
+ ("github.com/itchio/go-itchio" ,go-github-com-itchio-go-itchio)
+ ("github.com/itchio/hades" ,go-github-com-itchio-hades)
+ ("github.com/itchio/headway" ,go-github-com-itchio-headway)
+ ("github.com/itchio/httpkit" ,go-github-com-itchio-httpkit)
+ ("github.com/itchio/hush" ,go-github-com-itchio-hush)
+ ("github.com/itchio/intact" ,go-github-com-itchio-intact)
+ ("github.com/itchio/lake" ,go-github-com-itchio-lake)
+ ("github.com/itchio/mitch" ,go-github-com-itchio-mitch)
+ ("github.com/itchio/ox" ,go-github-com-itchio-ox)
+ ("github.com/itchio/pelican" ,go-github-com-itchio-pelican)
+ ("github.com/itchio/savior" ,go-github-com-itchio-savior)
+ ("github.com/itchio/screw" ,go-github-com-itchio-screw)
+ ("github.com/itchio/smaug" ,go-github-com-itchio-smaug)
+ ("github.com/itchio/spellbook" ,go-github-com-itchio-spellbook)
+ ("github.com/itchio/wharf" ,go-github-com-itchio-wharf)
+ ("github.com/itchio/wizardry" ,go-github-com-itchio-wizardry)
+ ("github.com/kballard/go-shellquote" ,go-github-com-kballard-go-shellquote)
+ ("github.com/klauspost/compress" ,go-github-com-klauspost-compress)
+ ("github.com/mattn/go-colorable" ,go-github-com-mattn-go-colorable)
+ ("github.com/mattn/go-runewidth" ,go-github-com-mattn-go-runewidth)
+ ("github.com/mitchellh/mapstructure" ,go-github-com-mitchellh-mapstructure)
+ ("github.com/natefinch/npipe" ,go-github-com-natefinch-npipe)
+ ("github.com/nightlyone/lockfile" ,go-github-com-nightlyone-lockfile)
+ ("github.com/olekukonko/tablewriter" ,go-github-com-olekukonko-tablewriter)
+ ("github.com/pkg/errors" ,go-github-com-pkg-errors)
+ ("github.com/russross/blackfriday" ,go-github-com-russross-blackfriday)
+ ("github.com/scjalliance/comshim" ,go-github-com-scjalliance-comshim)
+ ("github.com/shurcool/sanitized_anchor_name" ,go-github-com-shurcool-sanitized-anchor-name)
+ ("github.com/skratchdot/open-golang" ,go-github-com-skratchdot-open-golang)
+ ("github.com/stretchr/testify" ,go-github-com-stretchr-testify)
+ ("golang.org/x/crypto" ,go-golang-org-x-crypto)
+ ("golang.org/x/net" ,go-golang-org-x-net)
+ ("golang.org/x/sync" ,go-golang-org-x-sync)
+ ("golang.org/x/sys" ,go-golang-org-x-sys)
+ ("golang.org/x/text" ,go-golang-org-x-text)
+ ("golang.org/x/time" ,go-golang-org-x-time)
+ ("google.golang.org/protobuf" ,go-github-com-golang-protobuf-proto)
+ ("gopkg.in/alecthomas/kingpin.v2" ,go-gopkg-in-alecthomas-kingpin-v2)
+ ("gopkg.in/natefinch/npipe.v2" ,go-gopkg-in-natefinch-npipe-v2)
+ ("gopkg.in/yaml.v3" ,go-gopkg-in-yaml-v3)
+ ("xorm.io/builder" ,go-xorm-io-builder)
+ ))
+ (home-page "https://github.com/itchio/butler")
+ (synopsis "butler")
+ (description "butler is - all by itself.")
+ (license expat)))
diff --git a/golang.scm b/golang.scm
index 44ff4ca..9d937fa 100644
--- a/golang.scm
+++ b/golang.scm
@@ -1326,28 +1326,6 @@ representations of JSON are semantically equal. Create a new")
"Package pq is a pure Go Postgres driver for the database/sql package.")
(license license:expat)))
-;(define-public go-github-com-mattn-go-sqlite3
-; (package
-; (name "go-github-com-mattn-go-sqlite3")
-; (version "1.14.22")
-; (source
-; (origin
-; (method git-fetch)
-; (uri (git-reference
-; (url "https://github.com/mattn/go-sqlite3")
-; (commit (string-append "v" version))))
-; (file-name (git-file-name name version))
-; (sha256
-; (base32 "05fcdh6likz0hkvxnrkz3r3l5gzxfjh93w5015m9hs1wi6qpdqyb"))))
-; (build-system go-build-system)
-; (arguments
-; (list
-; #:import-path "github.com/mattn/go-sqlite3"))
-; (home-page "https://github.com/mattn/go-sqlite3")
-; (synopsis "go-sqlite3")
-; (description "Package sqlite3 provides interface to SQLite3 databases.")
-; (license license:expat)))
-
(define-public go-github-com-mitchellh-mapstructure
(package
(name "go-github-com-mitchellh-mapstructure")
diff --git a/prismlauncher-gpu.scm b/prismlauncher-gpu.scm
index 2a8e40c..2b30c3c 100644
--- a/prismlauncher-gpu.scm
+++ b/prismlauncher-gpu.scm
@@ -17,7 +17,7 @@
(define-public prismlauncher-gpu
(package
(name "prismlauncher-gpu")
- (version "8.0")
+ (version "8.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -27,7 +27,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0fdcv28phq0knd1a9isy04vpcb85q0jjz2ksjsxg14ya39rz0ac3"))))
+ "0kq3j9xck9gkf3l257vnv8kzf9bmxs7gxz54jzplr4wnim52nhy2"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
diff --git a/stablediffusion.scm b/stablediffusion.scm
index e4415e9..ffc0047 100644
--- a/stablediffusion.scm
+++ b/stablediffusion.scm
@@ -28,7 +28,7 @@
'(
#:tests? #f
;#:cmake "--config Release"
- ;#:configure-flags "-DSD_CUBLAS=ON -DGGML_OPENBLAS=ON --config Release"
+ ;#:configure-flags (list "-DSD_CUBLAS=ON -DGGML_OPENBLAS=ON --config Release")
#:configure-flags (list "-DGGML_OPENBLAS=ON --config Release")
)
)
diff --git a/stashley.scm b/stashley.scm
index 14a941f..4b86195 100644
--- a/stashley.scm
+++ b/stashley.scm
@@ -1,20 +1,20 @@
(define-module (stashley)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) :prefix license:)
#:use-module (guix packages)
- #:use-module (guix build-system copy)
+ #:use-module (guix build-system pyproject)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
- #:use-module (gnu packages video)
- #:use-module (gnu packages admin)
+ #:use-module (gnu packages)
#:use-module (gnu packages wget)
+ #:use-module (gnu packages video)
#:use-module (gnu packages python-xyz)
- #:use-module (ipfs-archive-manager)
)
(define-public stashley
(package
(name "stashley")
- (version "1.1.1")
+ (version "2.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -23,22 +23,27 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0sbr01pwig0szcgjbzncgbs2c3xnshfrzhw9jhccmy453sblwrll"))))
- (build-system copy-build-system)
+ "0x7zb604b3v2b9n531i9x31zqdgbrry4sa18xb94766a0scid05n"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (delete 'sanity-check)
+ )))
(inputs
(list
- ipfs-archive-manager
yt-dlp
gallery-dl
- python-yq
- fdupes
wget
- python-yq))
- (arguments
- '(#:install-plan '(("stashley" "/bin/stashley"))))
+ python-tomli
+ python-tomli-w
+ sherlock
+ ))
(synopsis "Program using TOML files to archive personalities to IPFS")
(description
"Stashley is a program used for archiving personalities using
TOML files, and if IPFS is installed, pushing them to IPFS.")
(home-page "https://git.techchud.xyz/stashley/")
- (license agpl3)))
+ (license license:agpl3)))