summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sherlock.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/sherlock.scm b/sherlock.scm
index e99c5b6..3168274 100644
--- a/sherlock.scm
+++ b/sherlock.scm
@@ -12,6 +12,7 @@
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages check)
#:use-module (gnu packages certs)
#:use-module (guix download)
@@ -92,12 +93,6 @@
))
(sha256
(base32 "0lb1r5fkwxm1zyxsax5aq3gp77gjz22i0agz6zyw5j9zrwb7c5g9"))
- (modules '((guix build utils)))
- (patches
- (search-patches "aux-files/sherlock/setuppy-support.patch"))
- (snippet
- '(begin
- (delete-file-recursively "images") #t))
))
(build-system pyproject-build-system)
(arguments
@@ -107,7 +102,7 @@
(delete 'sanity-check) ;we're going crazy, since sanity crashes.
)))
(native-inputs (list
- poetry
+ python-poetry-core
))
(propagated-inputs (list python-certifi
python-pandas
@@ -119,7 +114,7 @@
python-requests
python-requests-futures
python-stem))
- (home-page "https://sherlock-project.github.io/")
+ (home-page "https://github.com/sherlock-project/sherlock")
(synopsis
"Hunt down social media accounts by username across social networks.")
(description